[Logo] JCVSForum - Community Support For JCVS Users and Developers
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
The Hardy Boys and The Case of the Disappearing Projects  XML
Forum Index » JCVS Web
Author Message
tlacy


[Avatar]

Joined: 29/07/2004 09:06:53
Messages: 8
Offline

I'm using Apache 2.0.49 and Tomcat 4.1.30 on Windows XP Professional. I'm also
using the latest mod_jk2.so. I've got a remote repository on a Windows 2003
server and I'm accessing it from jcvsweb using the pserver protocol.

I've moved the config dir to WEB-INF/terrysConfig/, and I moved the default
project dir to WEB-INF/terrysConfig/project.

I create a user, login as that user, create a project and view and check it out.
All of this seems to work fine.

However, if I shut down and restart Tomcat, and then log back in to jcvsweb, my
projects disappear. I looked in the config and project directories, and the
project xml and project sub-directories are there, but jcvsweb doesn't see them.

Can you help the Hardy Boys solve this mystery?


Here's the project configuration file, if that helps (the password is obscured
here because I'm just paranoid, but there was an ampersand in it - could that be
causing problems?):

<?xml version="1.0" encoding="UTF-8"?>
<jcvs-project>

<jcvs-def>

<key>JBuildIt</key>
<type>jcvs</type>
<owner>tlacy</owner>
<name>JBuildIt</name>
<restricted>false</restricted>
<title>Java Build Utility</title>
<homepage></homepage>
<jcvsurl></jcvsurl>
<title>Java Build Utility</title>
<host>slcdeploy</host>
<method>pserver</method>
<port>2401</port>
<login>tlacy</login>
<pass>xxxxxxxx</pass>
<cvsroot>/CVS_REPOSITORY</cvsroot>
<localdir>WEB-INF/terrysConfig/project\JBuildIt</localdir>
<tempdir>WEB-INF/temp</tempdir>
<desc>A Utility for versioning, building, testing and deploying
applications.</desc>

</jcvs-def>

<!-- - - - - - - - - - - -->
<!-- VIEW DEFINITIONS -->
<!-- - - - - - - - - - - -->


<jcvs-view>

<key>HEAD</key>
<name>HEAD</name>
<title>JBuildIt HEAD</title>
<cvstag>HEAD</cvstag>
<module>JBuildIt</module>
<jump></jump>
<desc>The latest version of JBuildIt</desc>

</jcvs-view>

<!-- - - - - - - - - - - -->
<!-- MIME TYPE MAPPINGS -->
<!-- - - - - - - - - - - -->


</jcvs-project>
[Email]
Anonymous



tlacy wrote:I'm using Apache 2.0.49 and Tomcat 4.1.30 on Windows XP
Professional. I'm also using the latest mod_jk2.so. I've got a remote
repository on a Windows 2003 server and I'm accessing it from jcvsweb using the
pserver protocol.

I've moved the config dir to WEB-INF/terrysConfig/, and I moved the default
project dir to WEB-INF/terrysConfig/project.

I create a user, login as that user, create a project and view and check it out.
All of this seems to work fine.

However, if I shut down and restart Tomcat, and then log back in to jcvsweb, my
projects disappear. I looked in the config and project directories, and the
project xml and project sub-directories are there, but jcvsweb doesn't see them.

Can you help the Hardy Boys solve this mystery?


Here's the project configuration file, if that helps (the password is obscured
here because I'm just paranoid, but there was an ampersand in it - could that be
causing problems?):

<?xml version="1.0" encoding="UTF-8"?>
<jcvs-project>

<jcvs-def>

<key>JBuildIt</key>
<type>jcvs</type>
<owner>tlacy</owner>
<name>JBuildIt</name>
<restricted>false</restricted>
<title>Java Build Utility</title>
<homepage></homepage>
<jcvsurl></jcvsurl>
<title>Java Build Utility</title>
<host>slcdeploy</host>
<method>pserver</method>
<port>2401</port>
<login>tlacy</login>
<pass>xxxxxxxx</pass>
<cvsroot>/CVS_REPOSITORY</cvsroot>
<localdir>WEB-INF/terrysConfig/project\JBuildIt</localdir>
<tempdir>WEB-INF/temp</tempdir>
<desc>A Utility for versioning, building, testing and deploying
applications.</desc>

</jcvs-def>

<!-- - - - - - - - - - - -->
<!-- VIEW DEFINITIONS -->
<!-- - - - - - - - - - - -->


<jcvs-view>

<key>HEAD</key>
<name>HEAD</name>
<title>JBuildIt HEAD</title>
<cvstag>HEAD</cvstag>
<module>JBuildIt</module>
<jump></jump>
<desc>The latest version of JBuildIt</desc>

</jcvs-view>

<!-- - - - - - - - - - - -->
<!-- MIME TYPE MAPPINGS -->
<!-- - - - - - - - - - - -->


</jcvs-project>


I had the same problem. For now,you will have log in with user: admin pass:
admin and change the conf directory to your path. Path gets reset everytime.
Let me know if you find another solution to this.

tlacy


[Avatar]

Joined: 29/07/2004 09:06:53
Messages: 8
Offline

Anonymous wrote:

I had the same problem. For now,you will have log in with user: admin pass:
admin and change the conf directory to your path. Path gets reset everytime.
Let me know if you find another solution to this.



Hmm, that was not my experience. It doesn't look like the config path
is being reset. I zipped up the default projects, and they don't show
up any more, so I'm sure it is looking at the correct project path. It
just doesn't see any projects I add.
[Email]
time


[Avatar]

Joined: 05/06/2004 18:09:23
Messages: 367
Location: Bangkok
Offline

Hmm. This is very curious. At the moment, I am in Thailand, and my ability to
debug such things is limited.

However, I will upload a new 1.3.8 version very soon. This may fix the problem
that you are seeing. I say "may" because the jetlag is making me forget all the
things that I did just before my flight took off.

Please update to 1.3.8 when I upload it, and then let me know if this fixes your
problem. If not, then we will need to track it down together. Please watch the
announcements forum for the upload announcement.
[Email] [WWW]
time


[Avatar]

Joined: 05/06/2004 18:09:23
Messages: 367
Location: Bangkok
Offline

I have uploaded JCVSWeb 1.3.8.

This release fixes a bug with changing the location of the configuration and
losing the admin account login, as well as a couple of other minor issues
related to losing default configurations. No major changes to functionality.

Download here: http://www.jcvs.org/download/jcvs/jcvsweb-1.3.8.zip
[Email] [WWW]
 
Forum Index » JCVS Web
Go to:   
Powered by JForum 2.1.9 © JForum Team