[Logo] JCVSForum - Community Support For JCVS Users and Developers
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Problem executing the commit command with com.ice.cvsc  XML
Forum Index » JCVS Developers
Author Message
Anonymous



I'm new to CVS, so please excuse me if I'm asking stupid questions.

I'm using only the "com.ice.cvsc" package.

1) When I try to commit, I got the following error:

cvs server: Examining .
cvs server: Examining C:\Temp\Test
cvs server: Up-to-date check failed for `C:\Temp\Test/TestClass.java'
cvs [server aborted]: correct above errors first!

** The command completed with an error status.

I understand that "up-to-date check failed" is related to local copy not being
up-to-date with the one in the repository. But I have tried to run the "update"
command before "commit", and the result is the same. So is there any other
situations that will lead to the "up-to-date check failed" error?

2) Also, everytime when I run the "update" command, the local copy always gets
overwritten, no matter if I have the "-C" argument or not. It seems that the
server has never recongized there is a local copy. What did I do wrong?

In advance, thanks for your help!
time


[Avatar]

Joined: 05/06/2004 18:09:23
Messages: 367
Location: Bangkok
Offline

Your update problem, I believe, is related to "tags". You will need to perform
an "update -A" command to reset the tags to allow you to update in normal
fashion.

I am not sure that I understand your question regarding overwriting the "local
copy". I expect update to overwrite the local copy if the server has a newer
version. Unless you are expecting a merge request due to local updates. If so,
this may be related to the tags issue.

I must admit that I am not an expert on CVS and its usage, so you may wish to
use other forums directly related to CVS for these questions.
[Email] [WWW]
 
Forum Index » JCVS Developers
Go to:   
Powered by JForum 2.1.9 © JForum Team