[Logo] JCVSForum - Community Support For JCVS Users and Developers
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
WARNING: Maybe a bug!!!  XML
Forum Index » JCVS Developers
Author Message
Giant2



Joined: 05/11/2004 11:21:28
Messages: 1
Offline

Hi,
I'm trying to use JCVS to connect and do some operation (commit, checkout,
status,...).
During one of these (checkout) I see a strange thing:
When I did checkout command :co:N:AFP:deou: I see the program download correctly
the CVSFile, but raise an exception:
java.lang.NullPointerException
at com.ice.cvsc.CVSProject.processResponseItem(CVSProject.java:2053)
...
I try to see the code and it's referred to the UserInterface associated to the
request object. BUT I do not have this (for this reason is null pointer).
So, I try to see if this UInterface were used in other piece of code and see
that when UInterface is used an if... is called! Only in this piece of code it's
not called.
I try to add this in CVSProject.java (line 2053):
if (request.getUserInterface()!=null) ... and all goes well.

I believe you forget to add this line.

Hope this could help you in correcting bugs.

Bye all, Giant.

[Email]
time


[Avatar]

Joined: 05/06/2004 18:09:23
Messages: 367
Location: Bangkok
Offline

The code you refer to "assumes" that the UI interface is always non-null. The
patch you suggest is a good one and I will add it next release.
[Email] [WWW]
 
Forum Index » JCVS Developers
Go to:   
Powered by JForum 2.1.9 © JForum Team