[Logo] JCVSForum - Community Support For JCVS Users and Developers
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Messages posted by: rredmon
Forum Index » Profile for rredmon » Messages posted by rredmon
Author Message
Kristof,

This is just a duplicate reply after logging in so I'll get notified if you or someone else writes back. Sorry for the 1st anonymous post!

I believe I'm having the same trouble. I can use ssh to checkout/commit/etc to/from my repository, but I can't get the gui to work, probably because I don't have it setup correctly. Did your "Perform Test" response look like this?:

======================== CVSClient.processCVSRequest ========================
Command: noop
Repository:
RootRepository: /home/robr/cvsweb
CVSServer: 514@dag
RootDirectory: /home/robr/cvsweb
LocalDirectory:
Connect Method: RSH
Rsh Command: /usr/bin/rsh
Server Command: cvs server
isPServer? 'false' user 'robr' pass ''
There are no user set variables.
NumEntries: 0 NumArguments: 0
GlobalOptions: 0 GzipStreamLevel: 6
redirectOutput 'false' execInCurDir 'true '
sendEntries 'false' sendEntryfiles 'false'
sendModifieds 'false' sendEmptyMods 'false'
sendArguments 'false' ignoreResult 'false'
sendModule 'false' allowOverWrites 'false'
displayReponse 'false' handleUpdated 'false'
handleMerged 'false' handleCopyFile 'false'
handleEntries 'false' handleFlags 'false'
queueResponse 'true ' responseHandler 'null '
includeNotifies 'false' notifiesSize 'null'
*****************************************************************************
CVSRequest: opening server...
CVSClient.openServer: creating connection...
CVSClient.openServer: RSH argv[0] = '/usr/bin/rsh'
CVSClient.openServer: RSH argv[1] = 'dag'
CVSClient.openServer: RSH argv[2] = '-l'
CVSClient.openServer: RSH argv[3] = 'robr'
CVSClient.openServer: RSH argv[4] = 'cvs'
CVSClient.openServer: RSH argv[5] = 'server'
CVSClient.openServer: creating i/o streams...
CVSClient.openServer: server is open.
CVSRequest: server is open.
CVSClient.SENDLine: 'valid-requests'
CVSClient.READLine: '(null)'
PARSE: End of file on input stream.
Recevied an error from the cvs server while
requesting 'valid-requests'. This is not a good sign.




Short response, no status response from server.

Valid Requests: useUnchanged 'false' useDirectory 'true'
CVSRequest: send root directory...
CVSClient.SENDLine: 'Root /home/robr/cvsweb'
CVSClient.SENDLine: 'Valid-responses E M ok error Valid-requests Created Merged Updated Update-existing Removed Remove-entry New-entry Checked-in Checksum Copy-file Notified Clear-sticky Set-sticky Clear-static-directory Set-static-directory '
CVSRequest: Error sending command request.
CVSClient.buildErrorReponse: The CVS Request failed.
during processing of cvs request

**=========================================================================**

The CVS Request failed.
during processing of cvs request

** The command completed with an error status.
 
Forum Index » Profile for rredmon » Messages posted by rredmon
Go to:   
Powered by JForum 2.1.9 © JForum Team